Saturday, March 31, 2012

AIX INTERVIEW QUESTIONS


1. How do you create an LV?
Ans: #mklv –y lv_name vg_name PPs pv_name

2. How do you create a filesystem on a given LV?
Ans: # crfs –v jfs –d /dev/lv_name –m /mount_point

3. What is Journaled File System?
Ans: It maintains a log in corresponding log device before committing any changes to LV and thus maintains integrity of file system.

4. What are the types of filesystems in AIX?
Ans: JFS, JFS2, CDRFS, NFS

5. What are the differences between JFS and JFS2 FS?
Ans:  JFS- inode allocation while creating file systems is static
         JFS2 – Inode allocation is dynamic
         JFS- maximum file system size is 1 TB
         JFS2- Maximum file system size is 4 PB
         JFS- Inode size is 128 Bytes
         JFS2 – Inode size is 512 bytes

6. What is the file responsible to tell about the filesystems?
Ans: /etc/filesystems

7. How will you troubleshoot the file system problem?
Ans: using fsck and logform

8. Where you keep the shared folders in AIX?
Ans: /etc/exports

9. What exportfs –a command does?
Ans: It reads entries from /etc/exports and updates /etc/xtab

10. What is inode?
Ans: It is an Index node and points to the another inode or a datablock

11. What is superblock?
Ans: First block of any file system and contains Meta data of its like no of inodes and free list of inodes etc.

12. What is the daemon responsible for error log?
Ans: errdemon

13. What is the path for default log file?
Ans: /var/adm/ras/errorlog

14. How do you restrict remote user?
Ans: chuser rlogin=false user_name

15. How do you list filesystems?
Ans: lsfs

16. What are the stanzas in /etc/filesystem?
Ans: dev=, Mount=, Log=, Vfs=, Check=, Type=
         
17. How do you check error log?
Ans: # errpt -a

18. What is /proc file system?
Ans: contains process related information of all processes which are presently running.

19. What is the command to change the password of another user by a user –admin (other than root user) who can set the passwords for users?
Ans: pwdadm

20. In the above question user “admin” belongs to which group?
Ans. Security

21. How will you set the password for a user whose password length must be eight characters?

Ans: smit chuser or # chuser minlen=8 user_name Entries will be updated in /etc/security/user


22. Where is the password for a user stores?
Ans: /etc/security/passwd

23. What are the fields available in the: /etc/security/passwd file?
Ans: last update, password and flag

24. What are the fields available in /etc/passwd file?
Ans: username: password indication: uid: gid: gcos: homedirectory: shell

25. What are the actions will take happen while exporting vg?
Ans: Removes that vg entry from odm
Removes corresponding filesystem entries related to VG from /etc/filesystems.

26. One VG is exported from a system and imported in another system there created some new filesystems in that VG. Now to import that VG back to the old system what command you should execute?
ANS:   importvg –L –y vgname pvname

27. What is the VGDA information?
Ans: VG id, LV names, PV count, total PP’s, free PP’s, lv count, LTG etc.
(Use   # lqueryvg –p hdiskx –At)

28. While importing VG the /etc/filsystems will get updated, from where the information of file systems it gets?
Ans: LVCB of each lv (mount point information will reside in LVCB if the mount point length is less than 128 characters)

29. How will you set the customized UMASK for all users?
Ans: Add the entry in /etc/security/user- In default Section

30. What is LVM and its components?  What is the advantage of LVM in AIX.?
Ans: VG, PV, LV, FILESYSTEMS, File systems can be extended beyond the limit of PV size to multiple PVs.

31.  Can we add PV of different sizes into an existing VG? How to fully utilize the hdd space?
Ans Yes we can add PV of different sizes to existing VG. Change t factor

32. How you find out the characteristics of VG? What are the main features you look for?
Ans: #lsvg vgname.   NO. PPs, Free PPs, stale PPs etc


33. What is stale partition?
Ans: When a pp is out of synchronization it shows as stale partition.

34. How many PPs can be pointed by a LP? Is the size of LP increases with mirroring of PPs?
Ans: 3 PPs can be pointed a LP. No the size of LP does not increase with PP mirroring

35. What are the information you get in VGDA ?
Ans: PP size, PV count, max PPs, LV names etc, Free PPs,

36. What is the difference between VGDA & VGSA?
Ans:

37. What is LVCB?
Lvname, no of copies, inter policy, intra policy, no. of lps, lvid etc

38. What is quorum? Give details.
Ans: 51% of total VGDA information is called quorum

39. What is ‘t’ factor?
Ans:  by t factor we can increase max no. of PPs from default 1016. Ex: t2 will make 2032 max physical partitions.

40. How you make concurrent VG ?
Ans: mkvg –C –y vgname pvname

41. What are daemons in NFS ? Give details of each daemon ?
Ans : nfsd, rpc.mountd, rpc.statd, rpc.lockd and at client side biod

42. When we reopen an exported file after working on it we get stale error. What is the reason ?

43. What is the difference between network interface and network devices?
Ans: interface is logical device for tcpip networking, network devices are physical adapter.

44. How to add IP by aliasing to a network device ?
Ans: ifconfig en0 193.9.200.227 255.255.255.0 alias

45. What is netmask ?
Ans: to differentiate between network address and host address.

46. Give an example of class B network
Ans:  130.10.200.0

47. What is loopback address and its utility ?
Ans: IP address 127.0.0.1 is called loopback address and is used by the node to check the functioning of  its own tcpip sevices.

48. Where to add gateway in the network ? Can we use router as gateway ?
Ans: to connect between two different networks. Yes we can use router as gateway.

49. What is the difference between /etc/passwd and /etc/security/passwd ?
Ans: user information are stored in /etc/passwd . encrypted passwd is stored /etc/security/passwd

50. How to disable the lock of a user when he has crossed the failed login limits? Which is the file to look into it?
Ans: chuser account_locked=true user. /etc/security/user
51. What is the difference between systemwide profile and .profile of an user ?
Ans: ./profile of user overrides the env variables set by /etc/profile

52. What difference you find in #su root and #su – root ?
Ans: Su – root initializes the environment to that of root.

53. What is umask and why we require it ?
Ans: The umask value is deducted from default permission value 777 of a file when created.

54. What is tcb and how it works ?
Ans:  trusted computing base. When it is enable only trusted commands are executed by verifying with /etc/security/sysck.cfg.

55. What is quota and give full syntax of commands.
Ans: it fixes the limits for files and sizes for each user. Quota

56. What is trusted path and trusted shell?
Ans:

57. How you enable ACL in a file.
Ans: extended permission to be set in file. To set use the command acledit,aclget,aclput

58. How to find out the characteristics of an user ? What is difference between #lsuser and #lsattr?
Ans: lsuser, by lsattr we can find out the attributes of a device

59. What is the procedure to configure remote printer?
Ans: enable lpd daemon, create a queue and connect it to remote queue

60. What is difference between defined and available state in ODM ?
Ans: defined means it is already configured but not available for use. Available means the device is ready for use.

61. How you see maintenance level in AIX? What is the other command than #oslevel –r
Ans: instfix

62. How you install ML in AIX?   
Ans: #smitty update_all

63. What is the procedure in installing a package in AIX ? What is applied , commited, rejected states ?
Ans: applied –for testing of package only, committed: to install the package into the system. Reject: to reject the package if it fails in applied state

64. Can we install ML5 and ML6 simultaneously in applied state in same machine?
Ans: yes we can

65. If we remove ML5 from the m/c, will the ML6 will work ?
Ans: yes it will work

66. What is difference between backup and archive ?
Ans: archive: the backup data stored permanently for retrieval later date. Backup is a regular process like full backup, differential backup, incremental backup.

67. What is the difference between incremental and differential backup ?
Ans: In diff. Bacup it is compared with last full backup. In incremental backup it is compared to last backup.

68. What is crontab and how to schedule a job to run at 5pm on every Saturday?
Ans: to schedule to run a process at particular time. Edit the crontab file by crontab –e or crotab –l > crontmp, edit the crontmp by syntax m, h, day of month, month, day of week /process. Then start the process by crontab crontmp

69. What is the location where cron queues are being maintained
Ans: /var/spool/cron/crontabs

70. Where errorlog files are stored ?
Ans: /var/adm/ras/errlog

71. When there is a problen in a system what to do first ?
Ans: lookinto error log by errpt –a command

72. What is difference between errorlog and alog  files ?
Ans: alog gives the information on boot error.

73. What is the boot sequence in AIX and give the details of each step of booting.
Ans: 

74. What is mksysb backup? What are advantages we get out of it?
Ans: rootvg backup, sytem can be restored in case of failure, PP size can be changed, filesystem size can be reduced by shrink

75. Can we do the mksysb backup and savevg of other vg on same tape? Give the reason.
Ans: No

76. What is the procedure to retrieve only /etc/hosts file from mksysb tape? Give commands with exact syntax.
Ans: #tctl –f /dev/rmt0 rewind
  #restore –s4 –xqvf /dev/rmt0.1 ./etc/hosts

77. How you increase the size of a file system by 5GB? Give command details.
Ans: #chfs –a size=+5G /data

78. What are the tools available for performance monitoring?
Ans: sar, vmstat, topas

79. When you tell the system is CPU Bound or memory bound?
Ans: Run the sar command. If the value of %USER + %SYS is more than 80% we call the system is CPU bound. Run the vmstat command. If PI and PO is high we call the system to be memory bound.      

80. How will you check a given file system is large filesystem enabled?
Ans: lsfs –q fsname, if bf=true the given filesystem supports big filsystem

81. What is command to see MAC address of NIC
Ans: # lscfg –l ent0 –v

82. How will you check the serial no of the system?
Ans: uname –a

83. How will you see the parent device for en0?
Ans: # odmget –q “name like en0” CuDv

84. What is the fastpath for SSA RAID?
Ans. # smit ssaraid

85. How will you check the given hdiskn has how many no of Pdisks of your SSA box?
Ans: # ssaexlate –l hdiskn

86. What is the command to list all supported hardware by your system?
Ans: lsdev –P –H

87. How will you list the total no adapters your system have?
Ans: lsdev –Cc adapter

88. What is the command to see your dumpdevice?
Ans: sysdumpdev –l

89. What is the default dumpdevice?
Ans: /dev/hd6

90. List the file system hd1, hd2 etc and what they are meant for?
Ans:

91. How will you see the hard ware errors?
Ans: # errpt –d –H

92. How to clear the all errorlog messages?
Ans:# errclear 0

93. How to make the secondary dumpdevice permanently active?
Ans: # sysdumdev –P –s /dev/xxx.

94. Tell me the steps to replace the one hdd belongs to the mirrored rootvg?
Ans. Explain the detailed procedure

95. What is the command to move an lv to another hdd?
Ans: # migratepv –l lv_name hdiskx hdisky

96. How to disable a user from remote login?
Ans: # chuser rlogin=false user_name

97. How to prevent all users to login from the remote?
Ans: # touch /etc/nologin (Except root all users can not login from remote)

98. How to add a pv into a VG?
Ans: # extendvg vg_name pv_name

99. How to see the ftp service is running or not? How to enable it?
Ans: lssrc –s inetd, startsrc –s inetd or startsrc –t ftpd

100. What are the differences between IPAT over IP aliasing and replacement?
Ans: Explained the complete details of both methods.


101. What is the difference between MOUNT=TRUE and MOUNT=AUTOMATIC in /etc/filesystems?
Ans: OS related File systems which are mounted at the time of boot process will have ‘AUTOMATIC’ attribute and other filesystem which can be mounted along with system startup
Will have ‘TRUE’ attribute.

102. What is sticky bit and tell me example?
Ans: Sticky bit permission will be set to directory so as all user can make use of the files in that directory, but only owner can delete the file.

103. What is setuid and tell me example?
Ans: A file which is having SUID will be excuted as if its effective id Eg. /etc/passwd

104. If T and S permissions are set for the files what does it mean?
Ans: When Sticky bit and SUID permission set on directory and file which are not with executable permissions  set  respectively will shown like this.

105. How to check a VG is mirrored or not?
Ans: If a lp is mapped to more than one  pp by  lsvg –l vgname  command then VG is said to be mirrored.

106. What are the differences between AIX 5.1 and 5.3?
Ans:

107. What is the difference between UDP and TCP?
Ans:TCP- Connection oriented and acknowledgment for packet transmitted.
UDP-User Datagram protocol- Connectionless and no acknowledgment for the packets transmitted.

108. How to restore a single file of rootvg from mksysb backup tape media?
Ans: restore –S4 xvf /dev/rmt0 ./<filename>

109. How to format a log file system?
Ans: logform <device name>

110. What is the difference between applied and committed s/w?
Ans: applied state software can be rejected if don’t work properly if it suite then it can be committed. A software which was committed can‘t be rejected only way is uninstall.

111. How to commit applied state software?
Ans: installp –cgX <fileset name>

112. What is the difference between hard and soft mount in NFS?
Ans: For Hard mount the client keep tries to mount the file system until it succeeds. Where as the Soft Mount tries to mount the file system for few attempts if it is not succeeded in a given attempts it gives up.

113. What is the command to make the hdisk as bootable (bosboot)?
Ans: bosboot –ad /dev/hd5.

114. What is the lpp resource in NIM?
Ans. It has software image to be installed at client.

115. How to list all file systems?
Ans: lsfs

116. How will you edit the crontab?
Ans:    crontab –e
crontab –l > filename, edit file and crontab filename.

117. How do you list all volume groups?
Ans. Lsvg
118. How do you mirror rootvg?
Ans. Extendvg rootvg hdiskn, mirrorvg rootvg hdiskn, bosboot –ad, bootlist –m normal hdiskx, hdiskn.

119. What are the commands you used for performance monitoring?
Ans. Vmstat, sar, iostat, topas etc.

120. How will you come to know the system required more real memory using vmstat?
Ans. If pi and Po count is more (if paging activity is more even though it has enough paging space)

121. What is the use of AT command and how will you list the jobs?
Ans: One time operation for a given time. Atq –L

122. How do you exclude some file systems while taking mksysb backup?
Ans: By mentioning the file systems name in exclude.rootvg

123. How do you list the pv in system?
Ans: lspv

124. What are the AIX installation methods?
Ans: Complete and overwrite, preservation installation and migration

125. What are the prerequisites before attempting migration installation?
Ans: Take the system backup, check for hardware and s/w compatibility for newly installable os. Prepare with remedies for known problems.

126. How to roll back to the previous ML level if the newly installed ML had problem with applications.
Ans: If newly installed ML is in applied state, reject it. If it is committed state remove the fix and reinstall the previous ML.

127. What are the difference between applied state and committed state?
Ans: If we select applied state it will not replace the previous level and will have option to commit or reject the newly installed s/w. In committed state newly installed s/w will overwrite the existing s/w and will not have option to reject.

128. What is /etc/filesystems and what is its role?
Ans: /etc/filesystem has information regarding file systems, its mount point type of file system etc. Its main purpose to mount and check the file systems as per the parameters mentioned in it.

129. How to see the paging space?
Ans: lsps –a

130. How to increase the paging space?
Ans: chps –s pp’s  devicename.

131. What is the default paging space device?
Ans: hd6

132. What is ODM & Location of Database Files
Ans; ODM is database which contains the information of devices & system configuration. /etc/objrepos, /usr/lib/objrepos, /usr/share/lib/objrepos

133. Give details of each database files.
Ans: /etc/objrepos:  contains customized database
/usr/lib/objrepos:  contains predefined database
/usr/share/lib/objrepos:  contains software vital product data
134. How to set password history?
Ans: /etc/security/user

135. How to set two or three password?

136. What happens when execute exportvg & importvg?
Ans: Exportvg: removes info. of particular VG from ODM
  Importvg:  Add info. Of from VGDA of disk to ODM

137. What is NFS & file names of NFS?
NFS is distributed file system which provide remote access of file system.
File name:  /etc/exports

138. How to set permissions for exported directory?
Using /etc/exports

139. What are the types of Installation in AIX?
Ans: Complete/Overwrite Migration and Preservation Installation.

140. What is migration installation?
Ans:    For Upgrading the version of AIX.

141. Can we preserve /var file system in preservation installation?
Ans:    By default it removes /var files system. However by specifying in /etc/preserve.list we can retain the /var filesystem .

142. If you confirmed rootvg is completely crashed and no backup is available what are the actions to be performed?
Ans:    Reinstall OS, apply the required ML level and install /configure all apllications. Import all volume groups.

143. How to create a user using command prompt by specific home directory:
Ans:    #mkuser -a /xxxx/user1 user1

144. What is zombie process?
Ans:    It is dead process but it shows in the process list
 
145. What are LVM components?
Ans:     Explained all components like PPs, LPs, etc.

146. What is command to create LV
Ans:    # mklv  -t type  -y  lv_name  vg_name  no.of PPs   pvname

147. How to create a Vg:
Ans:    mkvg -y vgname  pvname1 pvanme2

148. What is the path for sulog?
Ans:    /var/adm/sulog

149. What is path for wtmp?
Ans:    /var/adm/wtmp

150. What is the path for failedlogin?
Ans     /etc/security/failedlogin


151. What makes difference when you su with - and without - ?
ANs:   With - env variable will set for newly switched user.

152. What are env variables?
Ans:    PATH, TZ, PWD, SHELL, EDITOR, etc.

153. What component we can not install once installation is carried out?
Ans:    TCB

154. How will you check whether TCB is installed or not?
Ans:    /usr/bin/tcbck

155. How will you list applied S/W?
Ans:    lslpp -l | gerp apllied

156. What is difference between applied state and committed state installation?
ANs    Applied state - Can be committed of rejected
          Committed state- Can not be rejected.

157. What is the difference between backup and archive?
Ans:    Backup: Performs regularly and recycle the media periodically.
          Archive: For preserving data for longer times and media should have good quality for preserving data and less seek time is required for data retrieval on need basis.

158. How to kill a process?
Ans:    By confirming the process whether it controlled by SRC or Init, if it is init use kill command of if it is by SRC use stopsrc.

159. What is shell?
Ans     Command intrepeter.

160. How to check ML version?
Ans:    # oslevel -r

161. If the system had ML version 7 and rootvg is courrpted and needs to restore mksysb. But mksysb backup was taken with ML5 How to go about?
Ans:     Restore mksysb and update new ML version with 7.

162. What is stickybit can we set it for file?
Ans:    To prevent deletion of each other files of users who had common directory?
          Stickybit set for a file is no use.

163. What is the purpose of chmod
Ans     To assign file/directory permissions for user/group/others

164. How will you check the attributes of a user?
Ans:    lsuser

165. How will you prevent user form logging remote?
ANs    # chuser -a rlogin=false username

166. If the uptime file is corrupted how will you see the server uptime?
Ans:    # who -b

167. What is the difference between differential and incremental backup?
Ans:    Differential backup will take the backup of the data modified w.r.t to its previous full backup whereas incremental backup will take the backup of modified data w.r.t its previous backup.
168. How do you add pv in shared vg?
Ans.    Explain detailed procedure.

169. What is the significance of 9 with kill command?
Ans:    It surly kills the process and will not save any

170. How will you list the specific attributes of a user?
Ans: lsuser -a id home username

171. How will u see the version and ML of AIX?
Ans: oslevel –r for version and instfix –ik |grep ML for ML

172. How will u check the errors during booting?
Ans: alog command

173. How will u check the errors after booting?
Ans: errpt command

174. Detailed information about NFS?
Ans: Explain about NFS and the daemons at server and client

175. What is LVM?
Ans. Logical Volume manager- explained its advantages and all of its components.

176. What is the parameter used for inodes while creating filesystem?
Ans: nbpi

177. Explain the installation procedure for installing AIX
Ans. Explained the complete installation procedure and narrated type os installation

178. How to repair a file system?
Ans.  Fsck and logform

179. What is super block?
Ans: First block of every file system which contains meta data of the file system and its alternate block is 31.

ALL THE BEST .................

Senthilkumar Muthusamy

10 comments:

  1. so useful sir ...!!!!! thank u so much :)

    ReplyDelete
  2. I am much interested to know more about the interview and recruiting process which are evolved. And i wanna thank you for posting this.

    Recruitment Consultancy in Bangalore

    ReplyDelete